Fehlermeldung: ​[Warning] 'Pluginname' is using deprecated hook 'OnNpcPlayerTarget', which will stop working on Wednesday, 01 April 2020. Please ask the author to update to 'OnNpcAttack(NPCPlayerApex npc)'​

  • [Warning] 'Pluginname' is using deprecated hook 'OnNpcPlayerTarget',

    which will stop working on Wednesday, 01 April 2020.

    Please ask the author to update to 'OnNpcAttack(NPCPlayerApex npc)'


    Wie Ihr bereits mitbekommen habt, gibt es seit dem letzten Event-Update die Fehlermeldung

    "[Warning] 'Pluginname' is using deprecated hook 'OnNpcPlayerTarget',

    which will stop working on Wednesday, 01 April 2020."

    in eurer Server Console.


    Ihr könnt die Warnung in der Console, Logs beruhigt ignorieren, die Developer haben oder sind bereits dran ein Update für betroffenen Plugins raus zu bringen oder wir müssen einfach warten, bis Oxide ein neues Update bekommt und es behebt.


    [Warning] 'Vanish v0.7.2' is using deprecated hook 'OnNpcPlayerTarget', which will stop working on Wednesday, 01 April 2020. Please ask the author to update to 'OnNpcAttack(NPCPlayerApex npc)'

    [Warning] 'BotSpawn v1.9.7' is using deprecated hook 'OnNpcPlayerResume', which will stop working on Wednesday, 01 April 2020. Please ask the author to update to 'OnNpcResume(NPCPlayerApex npc)'

    [Warning] 'ZoneManager v3.0.8' is using deprecated hook 'OnNpcPlayerResume', which will stop working on Wednesday, 01 April 2020. Please ask the author to update to 'OnNpcResume(NPCPlayerApex npc)'

    [Warning] 'ZombieHorde v0.1.25' is using deprecated hook 'OnNpcPlayerResume', which will stop working on Wednesday, 01 April 2020. Please ask the author to update to 'OnNpcResume(NPCPlayerApex npc)'

    [Warning] 'BarrelPoints v2.0.8' is using deprecated hook 'OnPlayerDie', which will stop working on Wednesday, 01 April 2020. Please ask the author to update to 'OnPlayerDeath(BasePlayer player, HitInfo hitInfo)'


    Wichtig:

    Der Fehler kann zu Performance Problemen führen!

    Wenn Ihr Probleme mit dem Servern habt, dann bitte diese Plugins vorübergehend deaktivieren und auf ein Update warten.


    Alle Angaben, ohne Gewähr & Anspruch auf Vollständigkeit